LoxBerry, die wohl beste (externe) Erweiterung für den Loxone Miniserver

Es hat mich die ganze Zeit geärgert das die Loxone 1-Wire Extension nicht alle, von mir benötigten, 1-Wire Bausteine unterstüzt. Nach langer Suche bin ich nun auf etwas gestoßen und ich habe es sofort ausprobieren müssen, die Rede ist hier von LoxBerry.

LoxBerry LoxBerry, die wohl beste (externe) Erweiterung für den Loxone MiniserverQuelle Image by Christian Wörstenfeld

Ein Raspberry Pi 3 (Model B) lag bei mir noch herum, eine 8GB Micro-SD-Card war auch vorhanden, also nichts wie ran gemacht und es ausprobiert.

Mich hat natürlich hauptsächlich das 1-Wire Plugin für LoxBerry interessiert, es ist flexibler und im Endeffekt auch günstiger, als eine Loxone 1-Wire Extension.

1-Wire-Icon-LoxBerry LoxBerry, die wohl beste (externe) Erweiterung für den Loxone MiniserverQuelle Image: http://www.loxwiki.eu/display/LOXBERRY/1-Wire

Wie in der Anleitung zu LoxBerry beschrieben also das Image herunter geladen, auf die SD-Card geschrieben und ab in den Raspberry Pi damit. Monitor per HDMI, Maus und Tastatur per USB, und das Netzwerkkabel angeschlossen und dann das Netzteil angesteckt

Der Raspberry Pi bootet und nach kurzer Zeit konnte ich mich mit einem Webbrowser auf die dem Rasberry Pi zugeteilte IP-Addresse verbinden. Dann den Installationsassistenten ausgeführt und das 1-Wire Plugin installiert. Geht alles nach den Anleitungen zum LoxBerry im Loxwiki einfach und schnell.

Jetzt wollte ich natürlich direkt mal einen Baldachin Multisensor über den LoxBerry abfragen, doch als ich den 1-Wire Bus durchsucht habe erschien….nichts 🙁

Also wo könnte der Fehler liegen, ich habe meinen selber gebauten 1-Wire auf USB Adapter genutzt und natürlich gedacht das die USB Einstellung im 1-Wire Plugin für diesen Adapter korrekt sei, doch dem ist nicht so. Ich musste in der owfs.conf (OWFS wird vom LoxBerry 1-Wire Plugin genutzt) den server: usb … in server: device = /dev/ttyUSB0 ändern.

Jetzt noch einmal den Rasberry Pi neu starten, und siehe da es funktioniert 🙂

1-Wire-Auflistung-300x145 LoxBerry, die wohl beste (externe) Erweiterung für den Loxone MiniserverDanach habe ich mir einen viruellen Eingang in der Loxone Config angelegt und mir einfach mal, wie im Wiki beschrieben, die Werte des DS2438 abgerufen und anzeigen lassen.

Wunderbar es geht!

Jetzt gibt es eine Anleitung im Wiki um die 1-Wire Sensoren per I2C am Raspberry Pi anzubinden, eine Platine wird auch dafür vorgestellt. Mich störte jetzt nicht nur der Preis dieser Platine sondern auch das noch eine Adapterplatine mit Spannungsreglern benötigt wird um diese Platine sinnvoll zu nutzen.

Also war die Idee für eine neue Platine geboren (klick hier) 😉

 

Verlinke diesen Beitrag:

<a href="https://blog.thomasheldt.de/loxberry-die-wohl-beste-erweiterung-fuer-den-loxone-miniserver/">LoxBerry, die wohl beste (externe) Erweiterung für den Loxone Miniserver</a>

The following two tabs change content below.
photo-80x80 LoxBerry, die wohl beste (externe) Erweiterung für den Loxone Miniserver

Thomas H.

Als Betreiber dieses Blog versuche ich hier interessante Projekte und Tipps rund um die Elektronik zu bieten.

6 Gedanken zu „LoxBerry, die wohl beste (externe) Erweiterung für den Loxone Miniserver

  1. vitala

    Hallo Thomas,

    kannst du evtl. die Preise schon nennen, ich bin gerade noch am schwanken, welche 1wire Extension ich mir holen soll. Wenn es deine wird, muss ich mir noch den Aufpreis vom Raspberry oben drauf Rechnen.

    Dann habe ich noch eine Frage, die Platine führt ja mehre 1wire Linien raus, werden alle Linien über die Gpios vom Raspberry mit strom versorgt? Oder wird es die Möglichkeit geben die Platine mit externen Stromversorgung zu versorgen.

    Dann schreibst du weiter oben, die von dir vorgeschlagenen Gehäuse, habe aber keinen Link zu den Gehäusen gefunden.

    Wann könnte man die Platinen den bestellen?

    Viele Grüsse

    Antworten
    1. Thomas H. Beitragsautor

      Hallo,

      die einzelnen Busse werden über den integrierten Spannungsregler versorgt, nicht vom Rasperry Pi, es ist alles getrennt.

      Das Gehäuse ist im LoxWiki beim 1-Wire Plugin beschrieben, ich werde das Gehäuse dann auch anbieten wenn alles funktioniert.

      Aktuell kann ich zum Preis noch nicht viel sagen, kommt etwas darauf an was ich noch an Zoll etc. für die ICs zahlen muss, aber günstiger als die original Extension wird es auf jeden Fall 😉

      Gruß
      Thomas

      Antworten
  2. Dieter Schmidberger

    „Also wo könnte der Fehler liegen, ich habe meinen selber gebauten 1-Wire auf USB Adapter genutzt und natürlich gedacht das die USB Einstellung im 1-Wire Plugin für diesen Adapter korrekt sei, doch dem ist nicht so. Ich musste in der owfs.conf (OWFS wird vom LoxBerry 1-Wire Plugin genutzt) den server: usb … in server: device = /dev/ttyUSB0 ändern.“

    Das Plugin arbeitet in der Config mit server: usb = all, alle USB-Adapter die ich testen konnte haben sofort funktioniert. Warum deiner nicht erkannt wurde muss kann ich nicht sagen.
    Denke aber in erster Line nicht das es ein Problem des Plugin selber ist. Die org. DS9490R machen auf jeden Fall keine Probleme.

    Antworten
    1. Thomas H. Beitragsautor

      Hallo Dieter,

      ich bin mir jetzt ziemlich sicher das es daran liegt das ich ja einen DS2480 in Verbindung mit einem FTDI FT230XS nutze, der PC sieht also einen seriellen USB Baustein und keinen USB 1-Wire Bridge Baustein.

      Aber da es ja einfach ist die Konfigurationsdatei zu ändern um serielle 1-Wire Bridges zu nutzen sehe ich da keinen weiteren Handlungsbedarf (Auswahl der seriellen Schnittstelle im Plugin) 😉

      Gruß
      Thomas

      Antworten
  3. Dieter Schmidberger

    Hallo Thomas,

    noch kurz was zur Spannungsversorgung des 1 Wire Bus.
    Ich habe über diverse Tests festgestellt das Wenn nur sehr wenigie Sensoren am Bus laufen, und diese auch noch in Sleep gehen um Strom zu sparen schaltet der Spannungsregler sich ab.
    Laut Datenblatt soll das bei <5mA sein.
    Ich teste gerade mit einem 1kOhm Widerstand der die 5mA aufrecht erhält, bis jetzt hatte ich keinen Ausfall mehr.
    Schau mal ob du ein ähnliches Verhalten feststellen kannst.

    Gruß
    Dieter

    Antworten
    1. Thomas H. Beitragsautor

      Hallo Dieter,

      ich setze Regler ein die keine Grundlast benötigen, aber zur Not einfach eine LED anschließen die die Spannungsversorgung gleichzeitig noch anzeigt 😉

      Gruß
      Thomas

      Antworten

Schreibe einen Kommentar zu Dieter Schmidberger Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.